Camisetas Guanabara.info !! Garanta já a sua!

VisuAlg v2.5

Categorias: Algoritmos, Programas

81 comente

Curso de Algoritmos

O VisuAlg é uma ferramenta criada pela Apoio Informática e é muito útil para quem está iniciando seus aprendizados em Lógica Computacional ou construção de Algoritmos Computacionais. Nele você pode digitar os comandos em Português e ver seu programa funcionando!

Na sua versão 2.5, o VisuAlg está em uma versão stand-alone, que funciona até mesmo em PenDrives.

Baixe o VisuAlg na sua versão mais recente no link abaixo.


Download

Related Posts with Thumbnails
  • Carlos Magno

    Otimo programa a V2, baixei a V2.5 para ver.
    Parabens

    Obrigado

    [Responder]

    outubro 16, 2007 @ 10:00 pm
  • Tiago Aguiar

    Esse programa é simplesmente FANTÁSTICO, ele é ótimo para quem está querendo aprender lógica de uma forma bem prática e muito fácil. Estava procurando um programa assim já faz um tempinho.

    Parabéns..

    Obrigado

    [Responder]

    outubro 28, 2007 @ 1:43 am
  • fabio

    Vou testar para ver se funciona…

    [Responder]

    novembro 18, 2007 @ 11:18 pm
  • guto

    estou estudando muito com as dicas e matérias deste site, obrigado pela oportunidade Gustavo, vlw

    [Responder]

    novembro 26, 2007 @ 7:57 pm
  • guto

    vou usar este programa depois durante a apostila e depois posto os resultados

    [Responder]

    novembro 26, 2007 @ 7:58 pm
  • Renato Souza

    Olá… boa apostila…fico muito grato de ter alguém como vc´s que possam ajudar quem está precisando estudar, abordando esses assuntos tão importantes.

    [Responder]

    janeiro 12, 2008 @ 3:52 pm
  • Rômulo

    Estou viciado na versão 2.0 e vou testar agora a 2,5 o visual é perfeito para validar algoritmos.

    [Responder]

    março 1, 2008 @ 9:22 pm
  • Glaucio Galvão

    A versão 2.5 é muito massa, gostei muito e sem contar que é prático, estão de parabéns obrigado pelo Download. um abraço

    [Responder]

    março 13, 2008 @ 12:09 pm
  • PÔ gostei demais do VisuAlg 2.5!
    Me interesso bastante por desenvolvimento
    de programas, essa aula foi show, mesmo!

    [Responder]

    abril 2, 2008 @ 3:50 am
  • e aí professor agora conseguí baixar o programa, tirei o linux e coloquei o windowsxp.obrigado por me avisar, já estava pensando que eu estava fazendo errado.

    [Responder]

    abril 5, 2008 @ 1:01 am
  • Andrée

    Aê guanabaramaníacos, alguém pode me dizer como faço no Visualg d2.5 para aparece o que eu desejo a tela ? Na hora de usar o comando imprima, no caso do programa é escreva, mas não aparece a mensagem na tela.Por exemplo :

    escreva ‘O preço total é ‘,preco, ‘.’
    não caso ele não mostra nada disso escrito na tela ele simplesmente fica preto e espera eu digitar, quando digito o resultado é computado na parte fora da tela preta. E o total como escrito acima não aparece na tela.
    Como faço isso ? Tem como fazer ?

    [Responder]

    Flavio Ramalho Respondeu:

    Caro Andre,

    Para exibir textos a sintaxe básica correta é:

    escrever (“O preço total é: “, preco)

    Sem mais,

    [Responder]

    Stefany Respondeu:

    Eu adorei o visualG, e muito interessante

    [Responder]

    abril 10, 2008 @ 10:58 am
  • Franklin Seixas da Silva

    E ai companheiro, gostaria de saber se há algum programa que rode registros.

    [Responder]

    Giuseppe G. M. Respondeu:

    @Franklin Seixas da Silva,
    Olá, notei sua pergunta e achei que poderia ser útil em responder, pois fiquei com a mesma dúvida, mas sei de um programa que aceita registros, é um software que uma empresa que faz cursos online produziu, seu nome é “SoftBlue IDE Logic”, você consegue ele fazendo um curso online da Softblue de “Lógica de Programação”, esse curso é gratuito, eles tem outros pagos, mas este é gratuito (a não ser que eles mudem), para você entender os comandos desse programa você vai ter que fazer esse curso, mas ele é simples, e pode ser feito em mais ou menos duas semanas, é bem interessante e gera um certificado quando você conclui o curso. E tudo de graça!

    [Responder]

    abril 17, 2008 @ 6:54 pm
  • Jennifer de Almeida - RJ

    Nossa!
    Eu ameii Professor!
    Muito melhor aprender aqui do que nada aula do ”Tio Xuxa” ( renato )!
    Amei mesmo!

    Muuito Bom!

    bjO!

    [Responder]

    abril 19, 2008 @ 12:33 pm
  • Anilso

    Ótima ferramenta para o aprendizado de lógica. É o tipo de coisa que o governo devia financiar para o desenvolvimento educacional do país.

    [Responder]

    Prof. Dr. Claudio Di Capua Respondeu:

    @Anilso,
    Creio que se o pessoal da Apoio Informática tornassem o projeto do VisuAlg em OpenSource e disponibilizasse o binário e o fonte no sourceforge, Git ou SVN já seria um bom início para o aperfeiçoamento do software, inclusive para incluir os paradigmas da programação orientada a objetos e programação funcional.
    Com isso teríamos uma ferramenta que iria além da proposta de desenvolver algoritmos em Português Estruturado.

    [Responder]

    maio 8, 2008 @ 4:08 pm
  • Neildo 27 anos RJ

    vlw meu Eee pc agradeçe

    [Responder]

    maio 11, 2008 @ 8:53 am
  • Christian

    andre..
    entao cara.. a sintaxe correta do comando escreva é
    escreva (“mensagem”)
    por exemplo
    escreva (“O preço total é”, preco, “.”)
    flw
    t++

    [Responder]

    maio 21, 2008 @ 7:46 am
  • Italo

    pessoal quantas variáveis o programa suporta?

    [Responder]

    junho 2, 2008 @ 8:25 pm
  • André Lucas

    Italo, Quantas couberem na sua memoria ram.

    [Responder]

    agosto 12, 2008 @ 2:20 am
  • Talita

    põ, gostei mto desse programa, conheci ele pqe usamos ele na escola ^^

    Bacanaa mesmo!

    .*

    [Responder]

    setembro 11, 2008 @ 6:14 pm
  • Diogo Moraes

    Olá galera..muito bom esse programa!!

    [Responder]

    janeiro 21, 2009 @ 5:03 pm
  • Francisco

    Ótimo programa. Sua sintaxe é simplificada, seus comandos são em português e acompanha uma apostila com método de ensino muito fácil, isso é tudo que alguém que quer aprender a programar precisa.
    O que eu não aprendi em 2 anos de faculdade eu aprendi com ele.
    Vocês estão de parabéns!

    var
    Nota: real
    Nome: caracter
    inicio
    escreva (“Nome: “)
    leia (Nome)
    escreval (“Qual nota de 1 a 10 você daria para o Visualg 2.5?”)
    escreva (“R: “)
    leia (Nota)
    se Nota = 10 entao
    escreva (“Esse programa é demais!”)
    senao
    se Nota > 10 entao
    escreva (Nome, “, eu perguntei de 1 a 10 e não maior.”)
    senao
    se Nota < 10 entao
    escreva (Nome, ” você é um otário!”)
    fimse
    fimse
    fimse
    fimalgoritmo

    [Responder]

    janeiro 24, 2009 @ 2:23 pm
  • Mary - 26 -Guarulhos- SP

    Olá para todos…
    :lol: Carammmmmbaaaaaaaaa, amei a aula…

    … continuem … eu amo aprender coisas novas …

    [Responder]

    abril 24, 2009 @ 2:27 pm
  • Lucius

    CARA ESTÃO MUITO BOA AS AULAS DE ALGORITMO ! :D SUPER FELIZ ! :!:

    [Responder]

    maio 16, 2009 @ 12:21 am
  • alberico

    ótimo para meu linux ubuntu

    [Responder]

    agosto 15, 2009 @ 10:04 pm
  • Adorei o programa
    GJ 5*

    [Responder]

    agosto 26, 2009 @ 10:28 am
  • Daniel

    CAra não tô conseguindo acessar as referências de linguagem do menu ajuda para dar um visu nos tipos de comandos…

    [Responder]

    outubro 1, 2009 @ 11:15 pm
  • Alexandre

    Qual a diferença entre entre a versão 2 e 2.5?
    nao percebi diferença!!

    [Responder]

    outubro 12, 2009 @ 10:39 pm
  • ygor de souza carvalho

    muito obrigado pelo programa ele e d++++++++++++++++++++++++++++

    [Responder]

    novembro 1, 2009 @ 12:50 am
  • Kenom

    Cara, vocês são fodas, continuem assim.

    [Responder]

    novembro 7, 2009 @ 9:43 pm
  • De acordo com o “Sobre” do programa, essa é a versão 2.0.

    Parece que não foi corrigido ainda o bug de apesar de deixar com cor de comentário, algo entre chaves (“{}”) é visto como parte do programa e dá erro. Vou tentar enviar um e-mail para o desenvolvedor.

    [Responder]

    novembro 12, 2009 @ 7:13 pm
  • Alves Teixeira

    var
    aux, cont : inteiro
    msg : caracter
    inicio
    cont <- 1
    msg <- "Oi!"
    para aux de 0 ate 10 passo 2 faca
    escreval(msg)
    msg <- "Tchau!"
    enquanto (cont < 10) faca
    escreval(msg)
    cont <- cont + 1
    fimenquanto
    msg <- "Oi!"
    fimpara
    fimalgoritmo

    [Responder]

    novembro 24, 2009 @ 7:01 am
  • Alves Teixeira

    este programa saiu-me em uma prova qual seria a execução?

    [Responder]

    novembro 24, 2009 @ 7:02 am
  • tiago ferreira

    não sei uq esta acontecendo no visualalgv2.5 que tenho aqui mais digito tudo sertinho ai quando vou executar ele da um erro na seção de comando porfavor me ajudem aguardo respostas

    [Responder]

    dezembro 21, 2009 @ 2:51 pm
  • rock n' roll

    he muito otimo ele nos da uma base de como aprender a linguagem c e c++

    [Responder]

    janeiro 24, 2010 @ 7:10 pm
  • Renata

    Muitooo bom. Eu já sabia programar mas resolvi ouvir o podcast para saber como é, e vi que se eu tivesse escutado o podcast antes eu teria aprendido mais rápido quando eu estava aprendendo rsrsrs.

    [Responder]

    fevereiro 27, 2010 @ 9:29 pm
  • algoritmo “semnome”
    // Função :
    // Autor :
    // Data : 7/3/2010
    // Seção de Declarações
    var
    nome: caractere
    a , b , media : real
    nota : real
    inicio
    escreva (” nome do aluno: “)
    leia (nome)
    escreva (” nota da primeira avaliacao: “)
    leia (nota)
    escreva (” nota da segunda avaliacao: “)
    leia (nota)
    escreva (” nota da terceira avaliacao: “)
    leia (nota)

    [Responder]

    março 7, 2010 @ 11:05 pm
  • Francisco

    Ótimo programa para quem está começando em algoritmo e lógica de programação e para aqueles que tem dificuldades.

    Parabéns.

    [Responder]

    março 22, 2010 @ 1:00 pm
  • artur

    Cadê o link???

    [Responder]

    março 24, 2010 @ 1:17 pm
  • Tulhao

    fala aii galera!! estou començando um curso de analese e desenvolvimento de sistemas.e tenho muitas duvidas porq meu prof° é um ze ruela ! em uma semana de aula não aprendi oque aprendi vendo a aula de vcs, to curtindo muito e tirando minhas duvidas..
    valew guanabara !!!

    [Responder]

    março 25, 2010 @ 1:46 pm
  • var
    ano , mes , dia , a , b , r: inteiro
    inicio
    escreval (” VAMOS CALCULA QUANTOS DIA VOCÊ JA VIVEU “)
    escreval (“_________________________________________”)
    escreval (“”)
    escreva (” QUANTOS ANOS VOCÊ TEM ?: “)
    leia (ano)
    escreval (“”)
    escreva (” EM QUE MÊS VOCÊ NASCEU ?: “)
    leia (mes)
    escreval (“”)
    escreva (” EM QUE DIA VOCÊ NASCEU ?: “)
    leia (dia)
    escreval (“”)
    a:=(ano*365)
    b:=(mes*30)
    r:=(a+b+dia)
    escreva (” VOCÊ JÁ VIVEU”,r)
    escreva (” DIAS “)
    fimalgoritmo

    [Responder]

    Maxuel Querino Respondeu:

    var
    dia , a , b , r: inteiro
    ano:inteiro
    mes:inteiro
    inicio
    escreval (” VAMOS CALCULA QUANTOS DIA VOCÊ JA VIVEU “)
    escreval (“_________________________________________”)
    escreval (“”)
    escreva (” QUANTOS ANOS VOCÊ TEM ?: “)
    leia (ano)
    escreval (“”)
    escreva (” EM QUE MÊS VOCÊ NASCEU ?: “)
    leia (mes)
    escreval (“”)
    escreva (” EM QUE DIA VOCÊ NASCEU ?: “)
    leia (dia)
    escreval (“”)
    a:=(ano*365)
    b:=(mes*30)
    r:=(a+b+dia)
    escreva (” VOCÊ JÁ VIVEU”,r)
    escreva (” DIAS “)
    fimalgoritmo

    [Responder]

    coiote 69 Respondeu:

    @Maxuel Querino,
    Ai galera, agradeço pelo site, esta me ajudando muito. Quanto ao algaritimo dos dias vividos, ele apenas faz a multiplicação das datas sem fazer a subtração da data atual. Tomando como data hoje 25.08.2013, se colocarmos os dados de uma criança que nasceu ontem 24.08.2013, temos anos 0, mês 08 e dias 24. O resultado será 264 dias . para que o algaritimo seja completo tem que haver a subtração da data atual (multiplicação de seus dias)pelos dias multiplicados referente aos dados informados . pergunto há um comado que informe a data atual em forma de constante para que aja essa subtração?

    [Responder]

    abril 4, 2010 @ 12:25 am
  • Fabiano

    Olá pessoal,
    Em primeiro lugar parabéns aos desenvolvedores do Visualg. Realmente é uma ferramenta muito interessante para quem está iniciando.

    Desejo saber também onde encontro uma lista de funções com suas sintaxes.
    Exemplos: Existe uma função parecida com truncar? Se o resultado for 4,45677832… como posso visualizar apenas 4,4 ou 4,45? E a função “mod”, como deve ser utilizada?

    Desde já agradeço a atenção.
    Obrigado!!!

    [Responder]

    abril 6, 2010 @ 12:37 am
  • o programa é da hora funciona certinho, valeu Guanabara.

    [Responder]

    abril 10, 2010 @ 1:44 am
  • gutemberg
    23 - belem

    ai galera bixo adorei esse progama ..
    mais to mandando um pacote de bosta pro meu amigo geovani. que me indicou esse progama .. valeu guanabara .. um abraço por traz ….kkkk

    [Responder]

    junho 9, 2010 @ 10:14 am
  • @paulocesadesign - 31 - Rio de Janeiro

    Ola Gustavo! Show de bola era tudo que precisavamos pra variar e customizar os calculos…
    Abs
    PC

    [Responder]

    junho 11, 2010 @ 11:38 pm
  • Silvano
    25 - Capanema-Pa

    Olá professor, gostaria de saber quais as plataformas de execulção do VisuAlg? e se ele é open source?

    Obrigado.

    [Responder]

    julho 8, 2010 @ 9:34 pm
  • agildo borges
    29 - recife

    gostaria de receber informaçoes sobre novas tecnologia!

    [Responder]

    agosto 21, 2010 @ 2:06 pm
  • G.Maia
    47 - São Paulo

    Ótimo aplicativo!
    Estou utilizando as duas versões.
    Para iniciação à lógica é muito recomendável.

    [Responder]

    setembro 4, 2010 @ 12:11 pm
  • Fabrício
    - Rio de Janeiro

    Excelente Programa, porém, esta é a versão 2.0. Ainda não existe versão 2.5.

    Estou utilizando este programa para dar aulas de algoritmos. É muito bom para o aluno, porém, este programa não trabalha com REGISTROS (Estruturas de dados heterogêneas). Ficou devendo só isso.

    [Responder]

    outubro 11, 2010 @ 11:07 am
  • Anderson

    var
    nota1,nota2,nota3,a,b,c,d : real
    i : real
    nome : caracter
    inicio
    // Seção de Comandos
    i <- 1
    repita

    escreva (" vamos calcular as notas dos alunos ")
    escreval()
    escreval()
    escreval (" insira o nome do aluno ")
    leia(nome)
    escreval (" insira a primeira nota do aluno ")
    leia(nota1)
    escreval (" insira a segunda nota do aluno ")
    leia(nota2)
    escreval (" insira a terceira nota do aluno ")
    leia(nota3)

    a <- nota1
    b <- nota2
    c <- nota3
    d 7 entao
    escreval (” Parabens voce esta aprovado “)
    escreval()
    escreval()
    escreval()
    senao
    escreval (” estude mais um dia voce consegui “)
    escreval()
    escreval()
    escreval()

    fimse
    i 10 entao
    escreva (” *********************END**********************”)
    escreva (” Creditos ao Anderson SA “)

    fimalgoritmo

    [Responder]

    janeiro 15, 2011 @ 5:58 pm
  • Rovilson Sarmetno
    36 - Brasilia

    Gostaria que alguem me auxiliasse na produção de um algoritmo de criptografia atbash,para que a pessoa digite um texto e seja criptografado.alguem se habilita,valeu e fico no aguardo.

    [Responder]

    abril 1, 2011 @ 7:10 pm
  • Heavy Hide

    algoritmo “ATBASH”
    // Função : Criptografa mensagens usando ATBASH
    // Autor : HeavyHide
    // Data : 16/06/2011
    // O programa criptografa e decriptografa, basta colocar a mensagem normal ou criptografada.
    var
    x,c : inteiro
    m,ma : caracter
    inicio
    escreva(“Digite uma mensagem :”)
    leia(m)
    ma <- ""
    para x de 1 ate compr(m) faca
    c = 65) e (c <= 90) entao
    c = 97) e (c <= 122) entao
    c <- 97 – c + 122
    fimse
    fimse
    ma <- ma + carac(c)
    fimpara
    escreva(ma)
    fimalgoritmo

    [Responder]

    junho 16, 2011 @ 12:08 pm
  • eu aki mosso
    14

    @Heavy Hide, kkkk q algoritmo noob nem funciona vai aprender mais antes de publicar aki
    oia o meu algoritmo
    algoritmo “forca”
    // Função :
    // Autor :
    // Data : 19/5/2011
    // Seção de Declarações
    var palsec,paljog:caracter
    qtd,num:inteiro

    inicio
    // Seção de Comandos
    escreva(“digite o nº de letras da palavra secreta “)
    leia(num)
    num “)
    leia(palsec)
    limpatela
    enquanto ((palsecpaljog) e (qtd<num)) faca
    escreva("Qual e a palavra secreta??? ")
    leia(paljog)
    limpatela
    qtd<-qtd+1
    fimenquanto
    se(paljog=palsec)entao
    escreval("parabens vc acertou!,o nº de tentativas foi ",qtd)
    senao
    escreval(" (-_-) ")
    escreval(" :—-!—-: ")
    escreval(" ! ")
    escreval(" ! ")
    escreval(" / \ ")
    escreval(" _/ \_ ")
    escreval("kkkk vc perdeu kkkk")
    fimse
    fimalgoritmo

    olha outro tbm q eu fiz

    algoritmo "carrodados"
    // Função :
    // Autor :
    // Data : 2/6/2011
    // Seção de Declarações
    var cor:vetor [1..50] de caracter
    placa:vetor[1..50] de caracter
    chassisnum:vetor [1..50] de caracter
    marca:vetor [1..50] de caracter
    cont:inteiro
    inicio
    // Seção de Comandos
    para cont<-1 ate 50 faca
    limpatela
    escreval("digite o numero da placa ")
    leia(placa[cont])
    escreval("digite a cor do carro ")
    leia(cor[cont])
    escreval("digite o numero do chassis do carro ")
    leia(chassisnum[cont])
    escreval("digite a marca do carro ")
    leia(marca[cont])
    fimpara
    fimalgoritmo

    [Responder]

    Maxuel Querino Respondeu:

    var
    palsec,paljog:caracter
    qtd,num:inteiro

    inicio
    // Seção de Comandos
    escreva(“digite o nº de letras da palavra secreta “)
    leia(palsec)
    limpatela
    escreva(“Qual e a palavra secreta??? “)
    leia(paljog)
    limpatela
    qtd<-qtd+1
    se(paljog=palsec)entao
    escreval("parabens vc acertou!,o nº de tentativas foi ",qtd)
    senao
    escreval(" (-_-) ")
    escreval(" :—-!—-: ")
    escreval(" ! ")
    escreval(" ! ")
    escreval(" / \ ")
    escreval(" _ / \_ ")
    escreval("kkkk vc perdeu kkkk")
    fimse
    fimalgoritmo

    [Responder]

    junho 20, 2011 @ 2:28 pm
  • vania
    49 - Belo Horizonte

    Bom dia, estou aprendendo Pascal e algumas mensagens tenho que trocar no Pascal. Tenho feito alguns programas, mas alguns não consigo executar(no meu curso usa o pascalzim) Poderia me ajudar a terminar o programa? Ja esta pronto mas da erro na hora de rodar, O sexo do participante pula e vai para a outra mensagem e a resposta não é a esperada. Pode me ajudar?
    Encaminho os 3 programas. 16 estão prontos, os outros 6 dão erro. Por estes, eu consigo resolver os outros.
    Program PesodoBoi;
    var Peso,PesoMaior,PesoMenor:real;
    Id,IdMaior,IdMenor:integer;
    Begin
    PesoMaior:=0;
    PesoMenor:=9999;
    clrscr;
    writeln(‘Qual é a idenficaçao do boi? 0=fim’);
    readln(Id);
    While Id>0 do
    Begin
    writeln(‘Qual o peso desse boi?’);
    readln(Peso);
    begin
    If Peso>PesoMaior then
    PesoMaior:=Peso;
    IdMaior:=Id;
    end;
    begin
    If Peso= 18) and (IDADE = 18) and (IDADE 0 do
    gotoxy(06,07);
    write(‘Qual a sua altura?’);
    read(Altura);
    gotoxy (06,07);
    write(‘Qual o seu peso?’);
    read(Peso);
    Massa:=Peso/(Altura*Altura);
    If (Massa25) and (Massa=40) then
    gotoxy(06,10);
    write(‘Voce é um obeso Mórbido’);

    end;
    Readkey;
    End.
    Obrigada desde ja.

    [Responder]

    julho 30, 2011 @ 8:47 am
  • GEAN RODRIGUES DA CRUZ
    16 - CURVELO

    parabéns muito legal esse programa !

    [Responder]

    novembro 12, 2011 @ 1:01 pm
  • Diego David
    25 - Fortaleza

    Deviam fazer esse visulg pra MAC tambem!!!!

    [Responder]

    março 15, 2012 @ 3:57 pm
  • Ze Geral

    Obs. A ajuda do programa não funciona.

    [Responder]

    abril 19, 2012 @ 8:52 am
  • eu sou muito visiado kkkkkk eu tenho o black ops

    [Responder]

    abril 29, 2012 @ 9:51 am
  • @SimonViegas - 30 - Salvador-BA

    Só para contar. NÃO EXISTE UMA VERSÃO 2.5 ainda. Essa versão é a 2.0!!!

    Duvida? Clique em “Ajuda”, depois em “Sobre”
    Att

    [Responder]

    junho 9, 2012 @ 1:50 pm
  • JOAO PAULO DE JESUS
    16 - CONCEIÇAO DA BARRA

    ESTE PROGRAMA E MESMO MUITO BOM PARA
    ESTRAGAR O MEU PC!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    [Responder]

    junho 11, 2012 @ 5:12 pm
  • JOAO PAULO DE JESUS
    16 - CONCEIÇAO DA BARRA

    ESTE PROGRAMA E MESMO MUITO BOM PARA
    ESTRAGAR minha maquina O MEU PC!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    [Responder]

    junho 11, 2012 @ 5:13 pm
  • Anonimo

    Meu profº nos deu no pen drive,pois ele é material de aula,e muito bom para aprender o basicao,e para depois passar para outra ferramenta,no meu caso será o java script

    [Responder]

    junho 12, 2012 @ 5:59 pm
  • Anonimo

    OBS:Esse programa é muito bom,eu sugiro

    [Responder]

    junho 12, 2012 @ 5:59 pm
  • KIn

    Uso esse programa no WIndows 7 – excelente programa; porém, uso também o Ubuntu 12.04 e ,não consigo executá-lo no Ubuntu. Alguém dá uma solução para esse meu problema.

    [Responder]

    Prof. Dr. Claudio Di Capua Respondeu:

    @KIn,

    Você poderá executar no Ubuntu via o Wine, mas será preciso instalar o Wine, então você poderá executar aplicativos Win32

    [Responder]

    julho 23, 2012 @ 11:47 pm
  • Stanley Rodrigues

    Eu estou iniciando com ele. É muito bom! Depois nós vamos pro C++.

    [Responder]

    dezembro 6, 2012 @ 4:30 pm
  • Danilo Pianco de Araujo
    - São Bernardo do Campo

    Parabéns Guanabara

    [Responder]

    janeiro 24, 2013 @ 12:39 am
  • José Alberto
    20 anos - Trindade (GO)

    Parabéns!!!

    [Responder]

    fevereiro 25, 2013 @ 12:41 pm
  • 46 - Pouso Alegre

    Ao pessoal da Apio Informática tornem o visualg opensource urgentemente, e formemos uma comunidade para dar prosseguimento a este projeto.
    É um produto muito usado inclusive nas faculdades de TI.

    [Responder]

    abril 25, 2013 @ 11:23 pm
  • Leonardo
    19

    Cara eu baixei , mas veio o 2.0…

    [Responder]

    maio 30, 2013 @ 10:41 pm
  • Raimundo Miranda Neto

    Não consigo usar variáveis do tipo REGISTRO.
    Apesar de baixar a versão 2.5 ., no menu AJUDA/SOBRE, o que aparece é versão 2.0. 2.5 também aparece no canto superior direito da IDE.
    Tem que melhorar isso. Perde a credibilidade.

    [Responder]

    junho 8, 2013 @ 1:57 pm
  • jhaemy
    32 - araguatins

    ele roda no windows 8
    visualg 2.5?

    [Responder]

    Simon Viegas Respondeu:

    @jhaemy, creio eu que essa versão é a 2.0 mesmo. E se roda no Windows 7 (32 e 64bits) creio que deve roda no Windows 8. Na pior das hipóteses: teste.
    Abraços

    [Responder]

    agosto 9, 2013 @ 10:05 am
  • coiote 69
    27 - macapá

    e galeta muito massa esse site. bom gostaria de saber se ha um comando que expresse a data atual para efetuar cálculos. exemplo numero de dias vividos.
    achei aqui no site o algaritimo, porém para que esteja completo tem que haver a subtração dos dias expresso pela data atual do dias calculados através da informação colida.. desde já agradeço a ajuda

    [Responder]

    agosto 25, 2013 @ 6:01 pm
  • coiote 69
    27 - macapá

    ai galera gostaria de saber o comando para expressar a data atual para cálculos de data. subtração de data atual pela informada. agradeço a ajuda

    [Responder]

    agosto 25, 2013 @ 6:04 pm

Comentar